Skip to main content
您好,欢迎光临IDC汇,需要什么服务器直接咨询客服,方便快捷。客服QQ 点击这里给我发消息
首页 > 服务器安全 »正文

apache漏洞修复

服务器安全 webadmin 2020-06-28 08:47:36 查看评论 加入收藏

1.SSL/TLS存在Bar Mitzvah Attack漏洞

 由于apache服务器未安装SSL模块,所以需要在不重新编译apahe的情况下安装mod_ssl模块。

 1.0 安装apxs,yum install httpd_devel;

 1.1 进入apache源码目录,进入module文件夹下的ssl目录;

 1.2 找到oepnssl 的include路径;

 1.3 运行/usr/local/apache2/bin/apxs -i -c -a -D HAVE_OPENSSL=1 -I /usr/include/openssl -lcrypto -lssl -ldl *.c;

 1.4 检查配置,重启。执行成功后可以在httpd.conf配置文件中看到已经添加了mod_ssl模块,apache  安装目录下的module中也创建了mod_ssl.so 文件。

 在apache中禁用RC4加密算法,在/etc/httpd/conf.d/ssl.conf中修改如下配置:

 SSLCipherSuite HIGH:MEDIUM:!aNULL:!MD5:!RC4

 重启apache服务:

 /etc/init.d/httpd restart


2.SSLv3存在严重设计缺陷漏洞(CVE-2014-3566) 

 在Apache 的 SSL 配置中禁用 SSLv3 和 SSLv3,在/etc/httpd/conf.d/ssl.conf中修改如下配置:

 SSLProtocol all -SSLv2 -SSLv3


3.检测到目标主机可能存在缓慢的http拒绝服务***

 限制web服务器的HTTP头部传输的最大许可时间,在/etc/httpd/conf/httpd.conf中添加如下配置:

 <IfModule reqtimeout_module>

    RequestReadTimeout header=5-40,MinRate=500 body=20,MinRate=500

 </IfModule>


4.SSL/TLS存在FREAK***漏洞

 更新openssl,在新的版本中已经得到修复,yum update openssl


5.点击劫持:X-Frame-Options未配置

 在/etc/httpd/conf/httpd.conf中添加如下配置:

 <IfModule headers_module>

   Header always append X-Frame-Options "DENY" 

 < /IfModule>


部分内容来源于网友们的贡献

广告06

微信