Skip to main content
您好,欢迎光临IDC汇,需要什么服务器直接咨询客服,方便快捷。客服QQ 点击这里给我发消息
首页 > 服务器安全 »正文

【网络知识点】高级交换技术

服务器安全 webadmin 2020-07-30 08:51:45 查看评论 加入收藏

高级交换技术

本文将通过实验展示高级交换技术里面关键知识点,主要以实际配置&关键注意点为主,其基础概念不会作解释。

 

实验环境:

GNS3,三层交换机使用C3640+交换接口模拟,二层交换机使用C3640+交换接口+关闭路由功能模拟,主机使用C7200+关闭路由功能模拟

【网络知识点】高级交换技术 

包含技术:

基础交换技术

高级交换防环:MSTP

高级交换冗余:网关冗余技术-HSRP

基础路由技术,OSPF基础配置

 

最终实现:

VLAN间能相互通信;VLAN10流量走R4-R2-R1主路线,备用路线R4-R3-R1,VLAN20流量走R4/R5-R3-R1主路线,备用路线R4/R5-R2-R1,在链路故障时可以自动切换备用路线;R2与R3之间做链路冗余,并且做了主备网关,R2为vlan10的主网关,vlan20的备网关,R3相反。

VLAN10网段为192.168.10.X 网关为10.254  VLAN20网段为192.168.20.X  网关为20.254  VLAN30网段为192.168.30.X ,vlan30隔离,只内部通信。

 

相关重点配置:

 

基础交换技术的配置就忽略了,具体参考上一篇博文《基础交换技术》

 

MSTP配置

在所有交换机配置

Config# spanning-tree  ---开启STP功能,CISCO默认开启

Config# spanning-tree mode mst ---定义STP模式为MSTP

Config#spanning-tree mst configuration

Config-mst# name CISCO ---定义MSTP名字

Config-mst# instance 1 vlan 10     定义实例1

Config-mst# instance 2 vlan 20,30   定义实例2

 

R2config# spanning-tree mst 1 root primary  ---实例1为主

R2config# spanning-tree mst 2 root secondary ---实例2为备

 

R3config# spanning-tree mst 2 root primary --- 实例2为主

R3config# spanning-tree mst 1 root secondary --- 实例1为备

 

show spanning-tree mst //查看

 

 

路由配置

R1(config)#int f0/0

R1(config-if)#no switchport //交换端口变路由端口

R1(config-if)#ip add 10.1.12.1 255.255.255.0

R1(config-if)#no shut

R1(config-if)#exit

 

R1(config)#int f0/1

R1(config-if)#no switchport

R1(config-if)#ip address 10.1.13.1 255.255.255.0

R1(config-if)#no shut

R1(config-if)#exit

 

R1(config)#int l0  //配置环回口,模拟外网

R1(config-if)#ip add 1.1.1.1 255.255.255.255

R1(config-if)#no shu

R1(config-if)#exit

 

R2(config)#int f0/0

#no switchport

R2(config-if)#ip add 10.1.12.2 255.255.255.0

R2(config-if)#no shu

R2(config-if)#exit

 

R3(config)#int f0/0

#no switchport

R3(config-if)#ip address 10.1.13.3 255.255.255.0

R3(config-if)#no shu

R3(config-if)#exit

 

R1(config)#router ospf 1

R1(config-router)#router-id 1.1.1.1

R1(config-router)#network 10.1.12.0 0.0.0.255 area 0

R1(config-router)#network 10.1.13.0 0.0.0.255 area 0

R1(config-router)#network 1.1.1.1 0.0.0.0 area 0

R1(config-router)#exit

R1(config)#

 

R2(config-router)#rou

R2(config-router)#router-id 2.2.2.2

R2(config-router)#network 10.1.12.0 0.0.0.255 area 0

R2(config-router)#network 192.168.10.0 0.0.0.255 area 0

R2(config-router)#exit

 

R3配置参考R2

 

HSRP配置

 

R2(config)#int vlan 10

R2(config-if)#ip address 192.168.10.253 255.255.255.0

R2(config-if)#standby 10 ip 192.168.10.254

R2(config-if)#standby 10 priority 150

R2(config-if)#standby 10 preempt

R2(config-if)#exit

R2(config)#int vlan 20

R2(config-if)#ip address 192.168.20.252 255.255.255.0

R2(config-if)#standby 20 ip 192.168.20.254

R2(config-if)#standby 20 priority 100

R2(config-if)#standby 20 preempt

 

R3(config)#int vlan 10

R3(config-if)#ip address 192.168.10.252 255.255.255.0

R3(config-if)#standby 10 ip 192.168.10.254

R3(config-if)#standby 10 priority 100

R3(config-if)#standby 10 preempt

R3(config-if)#exit

 

R3(config)#int vlan 20

R3(config-if)#ip address 192.168.20.253 255.255.255.0

R3(config-if)#standby 20 ip 192.168.20.254

R3(config-if)#standby 20 priority 150

R3(config-if)#standby 20 preempt 

 

 

监控远端故障,实现快速切换

R2(config)#track 10 interface f0/0 ip routing

R2(config-track)#exit

R2(config)#int vlan 10

R2(config-if)#standby 10 track 10 decrement 100

R2(config-if)#exit

 

测试:

原本:

R6#traceroute 192.168.20.2

 

Type escape sequence to abort.

Tracing the route to 192.168.20.2

 

  1 192.168.10.253 32 msec 32 msec 44 msec

  2 192.168.20.253 44 msec

    192.168.20.2 40 msec 20 msec

 

关闭:

R2(config)#int f0/0

R2(config-if)#shut

*Mar  1 01:47:48.447: %HSRP-5-STATECHANGE: Vlan10 Grp 10 state Active -> Speak

 

R6#traceroute 192.168.20.2

 

Type escape sequence to abort.

Tracing the route to 192.168.20.2

 

  1 192.168.10.252 40 msec 44 msec 28 msec

  2 192.168.20.2 32 msec 20 msec 48 msec

 

恢复:

*Mar  1 01:48:33.547: %HSRP-5-STATECHANGE: Vlan10 Grp 10 state Standby -> Active

 


广告06

微信